Rhino7 integration - Problems with materials and textures

Discuss Simlab Composer released by Simlab Soft
Post Reply
cyana
Posts: 131
Joined: Thu Jul 25, 2013 1:49 am

Rhino7 integration - Problems with materials and textures

Post by cyana » Tue Dec 15, 2020 1:59 am

Dear SimLab,

I recently upgraded to Rhino7 and hence also upgraded the exporter rh7 -> Composer.
Unfortunately, I now encounter a heap of problems with the materials - this partly might be Rhino related, not sure about that.

First and foremost - a lot of textures are not exported correct. I reported this already with Rhino5, however it obviously has not been fixed:

Image

Second, a wrong ambient color sometimes is used for the imported material, as you can see above

Third - the material names are not imported anymore, instead, a custom name (Material-xyz) is used:

Image

thanks
Cyana
Attachments
bug-2.png
bug-1.png

User avatar
SimLab
Posts: 3281
Joined: Mon Jan 04, 2010 8:09 am

Re: Rhino7 integration - Problems with materials and textures

Post by SimLab » Tue Dec 15, 2020 9:47 am

Do you have a model that you can share the issues, I will ask developers to check this.

I will try to compare Rhino 6 to Rhino 7 behaviors to check any changes.

cyana
Posts: 131
Joined: Thu Jul 25, 2013 1:49 am

Re: Rhino7 integration - Problems with materials and textures

Post by cyana » Tue Dec 15, 2020 11:53 am

Hi SimLab,

thank you for your reply. Attached a small demo file.
bug-1.png
You see the messy texture, and also the incorrect Ambient setting. Also, the material names are missing.

thanks
Cyana
Attachments
Demo3.zip
(9.73 MiB) Downloaded 3 times

User avatar
SimLab
Posts: 3281
Joined: Mon Jan 04, 2010 8:09 am

Re: Rhino7 integration - Problems with materials and textures

Post by SimLab » Wed Dec 16, 2020 5:26 pm

Cyana,

Do you use the integration plugin? or do you import the 3DM file directly to SimLab Composer?

We update version 10.17, when reading the 3DM file it gives the following material names

Rhino-materials.png

Please let me know if this addresses the issue for you

cyana
Posts: 131
Joined: Thu Jul 25, 2013 1:49 am

Re: Rhino7 integration - Problems with materials and textures

Post by cyana » Thu Dec 17, 2020 8:35 pm

Hi SimLab,

thank you for your reply. I'm exporting the model from Rhino to SC. Opening it directly with SC does not work, because it imports only a small fraction of the model:
TB-1.png
However yes - using direct import keeps the material names.
As for the textures - they are a complete mess after a direct import:
TB-2.png
thanks
Cyana

User avatar
SimLab
Posts: 3281
Joined: Mon Jan 04, 2010 8:09 am

Re: Rhino7 integration - Problems with materials and textures

Post by SimLab » Thu Dec 17, 2020 9:05 pm

Can you try to view it rendered in rhino before export

cyana
Posts: 131
Joined: Thu Jul 25, 2013 1:49 am

Re: Rhino7 integration - Problems with materials and textures

Post by cyana » Fri Dec 18, 2020 12:27 am

Hi SimLab,

do you mean 'Raytracing' (as the result above stems from 'Rendered')

Here the export from raytracing setting - it's even worse:
TB-1.png
thanks
Cyana

User avatar
SimLab
Posts: 3281
Joined: Mon Jan 04, 2010 8:09 am

Re: Rhino7 integration - Problems with materials and textures

Post by SimLab » Fri Dec 18, 2020 10:17 am

Just to make sure I understand the issue

Is it missing geometry?
wrong material names?
or texture/texture coordinates?

cyana
Posts: 131
Joined: Thu Jul 25, 2013 1:49 am

Re: Rhino7 integration - Problems with materials and textures

Post by cyana » Fri Dec 18, 2020 5:15 pm

Hi SimLab,

four issues.
1. missing material names - new with importer for Rhino7. Does not happen when directly importing into SC

2. messy textures - happens all the time, regardless whether you are importing directly or via integration. Might also be a Rhino issue in some cases.

3. missing geometries - only happens when importing directly. Seems that direct import ignores block definitions and imports the main model only. This is an issue since the very first SC version, but I gave up on this over the many years ;)

4. New with Rhino7 importer, ambient material color is gray instead of black. Have not really found out how and why this happens as not every material is affected - so it might be an issue with Rhino7, not with SC.

thanks for listening
Cyana

cyana
Posts: 131
Joined: Thu Jul 25, 2013 1:49 am

Re: Rhino7 integration - Problems with materials and textures

Post by cyana » Fri Dec 18, 2020 5:24 pm

In case you need a ranking - the texture issue is the most important problem for me. The building instructions for my project totally rely on proper textures. The project is not yet finished so I can switch to other parts meanwhile, however I cannot finalize without a building instruction.

thanks
Cyana

Post Reply